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Now that you’ve creating your milling toolpath in Powermill and created the program files in 
Codebreaker using the previous Milling with Powermill on the Kuka Robot tutorial, you’re 
ready to copy those .src program files to the robot and run them.

I.	 Turning on the Robot

If it’s not already on, turn on the Kuka robot using the two large switches on the wall to 
the left of the robot computer, turning on the far left switch first.  Make sure the robot 
is on before logging in to the robot workstation.

Once the robot has powered on, you’ll see the Navigator screen on the robot 
controller (also known as the pendant), along with a message in the bottom pane of the 
Navigator screen saying “PowerOn finished.”

The Navigator Screen



II.	 Copying your Program Files to the Robot

Log in to robot workstation with your net ID and password.  If the robot is on, you’ll see  
the Kuka Drop folder mapped to the K drive.  This is the shared drive that is used to 
pass files to the robot.

Navigate to the the “Kuka Drop” folder on the K drive and delete any files currently in 
the folder, then copy your .src files outputted from Codebreaker into the folder. 

Your program files are now on the shared drive of the Kuka’s embedded computer, but 
you’ll need to copy them to the Kuka’s NC Programs folder to run them.



Using the Pendant

On the Kuka pendant, the 
controller buttons around the 
screen correspond to the 
menus and buttons displayed 
directly next to them on the 
screen.  For example, to select 
the File menu, which is at the 
top left of the screen, you 
would press the leftmost 
button in the row of control 
buttons that runs along the 
top of the pendant face.

The arrow buttons at the 
bottom right of the pendant 
face are used to navigate 
through menus, and the yellow Enter button next to 
the arrows is used to select.  In the menus in the 
Kuka interface, if a number is displayed next to a 
menu item, you can use that number in the keypad to 
select that item as well.

The blue Tab button is used to cycle through the 
three panes of the Navigator window.

Setting the User Mode

To see the mapped Kuka Drop folder in the Kuka interface, you need to make sure 
you’re in Expert user mode.  To put the Kuka in expert mode, select Configure from 
the top menu using the corresponding top control button, then use the arrows to select 
Configure > User Group to open the User Group window.

In the User Group window, select the bottom control button that corresponds to 
Expert and enter the password “kuka” when prompted.

Copying files to NC Programs

In the top left pane of the Navigator screen, use the arrow keys to navigate to the Kuka 
Drop folder in the KUKA_DATA (D:\) drive. Using the Shift key, highlight all of your files 
and select Edit > Cut to move them from this folder.  

Navigate to the Programs folder in the R1 directory.  Select the files currently in the 
Programs folder and delete them using Edit > Delete, then copy your files into the 
folder using Edit > Paste.



III.	 Homing the Kuka and Changing the Tool

Homing the Kuka

Before running any programs on the Kuka robot, you should 
always send it to its home position to avoid problems or 
collisions.

Navigate to the NC Utilities folder, highlight the gohome 
program, and press the yellow enter button to open it. Once 
the program opens, squeeze the grey deadman switch until 
it’s partially (but not completely) depressed.  You’ll know the 
deadman is active when the red letter I at the bottom left of 
the screen becomes green.

Press the uppermost green button on the left 
side of the pendant to run the program (the 
letter R will also turn green, showing the 
program is running).  

The robot should now move to its initial home position.  You 
can change the speed settings on the right side of the 
pendant screen by toggling the corresponding button.  

Once the Robot is at the home position, select Program > 
Cancel Program to cancel out of the program and close that program window.

Changing the Tool

In the NC Utilities folder, open the changetool program.  In the program, use the 
arrows keys to move the cursor to the line in the program which precedes the line for 
your tool change and press Line Select.  (For example, if you’re using tool #5, scroll 
down to the line above the line for tool 5,1).  

With the proper line is selected, hold down one of the deadman buttons on the 
underside of the pendant and press the uppermost green Start button to start the tool 
change.  Note, the deadman needs to be continually held down when running any 
program, including tool changes, unless you’re in auto mode.  Releasing the deadman 
will immediately cause the robot to stop.

Once the robot moves to the toolbox and the toolbox opens, press the Start button 
again, all the while holding down the deadman. The robot will exchange the tool it’s 
currently holding with your desired tool, then measure the tooltip using the laser. This 
will take anywhere between 30 and 60 seconds and require the tool to move up and 
down in the laser bracket several times. It is important to make sure you do not let go 
of the deadman or the go button during this time.

Once the tool is measured, cancel the changetool program to close it.

The robot in home position



IV.	 Setting Your Base

Next, you need to tell the Kuka where your base point is located.  Remember, your 
base is the fixed point where all movements in your toolpath are measured from, so it’s 
crucial that this is set correctly.

To set your base, you’ll need to manually move the robot using the control buttons.

Moving the Robot Manually

Change to manual control mode by toggling the control button in the upper 
left corner until the robot icon looks like the picture to the right (by default, 
manual control of the robot is turned off, and this icon will have a red X 
through it).

Toggle the control button corresponding to the running man icon until the 
running man is red (if he’s not already).  This isn’t necessary for manually 
controlling the robot, but is necessary for running your programs later.

When in manual mode, the icons on the right of the Navigator screen will 
change.  These icons represent the speed and manner in which the robot will 
move.  For setting your base, you want to set the robot to world mode: toggle 
the fourth control button down on the right until you see a globe icon with 
arrows on it (as shown in the diagram on the right).  

Since this is your first time running the robot, you’ll want to run it at half-speed 
or slower.  Adjust the manual speed control button (the bottom icon in the 
diagram on the right) until the icon reads 50%.

Activate the deadman.  When the deadman is active, the icons on the right 
will change again to read X, Y, Z and A, B, C with +/- signs (if they say 
something like A1, A2, etc., you’re not in world mode).  X, Y, Z correspond to 
the axes of the robot (hitting +X will move the robot in the positive X axis) and 
A, B, C correspond to the drill head.  

Experiment with moving the robot manually by holding down the deadman 
and toggling these buttons.  Make sure you’re running at half-speed or slower, 
and take extreme care not to hit anything.  

Now that you’re comfortable with moving the robot, you can measure your 
base.



Measuring your Base

Select Setup > Measure > Base > 3 Point

You will be asked to choose a base number and 
name.  Set the base number to the same base 
number you set previously in Codebreaker.  If you’ll 
be using this base again later, you can give it a name 
for identifying purposes, then select OK.

Next, you’ll be asked to enter your Measurement 
tool number, which is the number of the tool you’ve 
changed to and will be using in your milling job.  
Enter the number, then select OK.

Next, you’ll be asked for your origin.  Using the 
manual controls, jog the robot to where the origin of 
your block would be.  If you’ve set the base to a top 
corner of your block, this will just be an 
approximation to verify your toolpath, so the 
placement doesn’t need to be exact.  If you’ve set the base to a bottom corner of your 
block, you should mark this point on the floor or workbench so that you can align your 
block exactly to this point when you set up your block.

Select OK once you’ve moved the tool to the right location.

NOTE: it’s crucial that your base point is set to this same point on your block in Powermill.  If your 
base point is set to a bottom corner of your block in Powermill, you should move the tool to where the bot-
tom corner of your block will be placed; if you used a top corner, you should move the tool to the point in 
space where the top corner of your block will be.  If your base in Powermill is set incorrectly, the robot will 
begin milling in the wrong location.

Next, you’ll be asked for a positive X sampling. Jog the robot a few inches in the 
positive x direction and select OK.  

Next, do the same for positive Y and select OK.

Once you have input this information, select Save.  Then send the robot home using 
the gohome program as described previously.



V.	 Testing and Running Your Job

 
The next step will be to run a test of your job without using any material, to verify that 
your toolpath starts correctly without running the risk of damaging your block.

Because this is a test, set the program speed to 30% or lower.  If there’s an issue with 
the base point or model orientation in your program, the robot could attempt to go 
somewhere unexpected and cause damage, so you want to run the program at a slow 
speed when starting so that you can stop it if necessary (the robot moves faster than 
you might expect).

Navigate to your job in the R1 > Programs folder and find the .src file that is labeled 
Main.  This is the main “control” program which calls the other sub-programs as 
needed.  Highlight the Main program and open it using the yellow enter button.

Hold down the deadman, then hold down the green Start button to start running your 
program. While holding the deadman you may have to press the Start button a couple 
of times after the robot’s initial plunge move. 

Continue to hold the Start button and the deadman as your program runs and verify 
that the robot is running your toolpath properly.

Load your block and begin cutting

Now it’s time to begin cutting your model.  Load 
your block, making sure to clamp it down securely 
on all four sides.  Also make sure that your clamps 
are not in the cutting path of your model.  If you 
set your base to a bottom corner of your block, 
make sure to align your block to the base your 
marked previously.  If not, set the base point again 
following the instructions outlined above, making 
sure to bring the tool tip right to the surface of your 
piece so it’s touching.  

Again, make sure this corresponds to your 
model’s base point in Powermill.

Launch your program as described above and run 
it again.  The robot will begin cutting your block.

Once you’re sure the cut is going properly and 
your feeds and speeds are correct, you can 
increase the speed to 100% and put the robot in 
Auto mode so that you don’t need to keep holding the deadman.



Switch to Auto mode

Let go of the deadman: the job will stop and so 
will the spindle.  

On the lower left side of the robot cabinet, there 
is a key which is in T2 mode. Turn it one notch 
to the right to AUTO. 

Next, reset the invisible fence by pressing the 
blue Reset button on the robot cabinet. When 
pushed, the button will light up blue.  If the 
fence becomes tripped again by someone 
moving through it, the blue light will turn off and need to 
be pressed again.

On the pendant, tab down to the bottom 
window and press Acknowledge All” to 
acknowledge operator safety, then press 
the Auto-mode Acknowledge button with 
the vertical line at the top right corner of 
the pendant.

A red message will pop up asking if you would like to 
restart the spindle: click YES.  

Once the spindle has started, press the green Go button 
on the pendant once to start milling again.


